Yealink SIP-T58W PRO IP phone Grey LCD Wi-Fi
YealinkGBP 286.75 There is one offer for this product.
T58W(Pro) with Camera*T58W Pro with Camera is equipped with the Bluetooth handset BTH58 by default.Elite Desktop Collaboration DeviceNext-Gen Desktop CollaborationFeaturing a vivid 7-inch touchable and adjustable color screen. the T58W(Pro) with Camera is positioned to bring premium-level. industry-leading communication journey with the new UI. five-megapixel camera and multi-way audio/video mixed conferencing.Free from Cord Constraint. Free from Distracting NoiseAdopting the innovative Bluetooth handset. Yealink T58W Pro with Camera pervades wireless communication by allowing the user to move around freely and conveniently.The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.Take Smart Business Phone to the Next LevelBoost by the upgraded chipsets. the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption. authority management. response speed and integratability to meet requirements of modern business and future sustainability.Enterprise-level Security. Provision and ManagementTaking data security as one of the most significant concerns. the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.By supporting Yealink/Unify Square Device Management Platform. the management. provision and update of the T58W Series can be implemented in a streamlined and simplified manner.
Compare offers
-
PcNova UnknownGBP 286.75
Specifications
Design
- Product type
- IP Phone
- Handset type
- Wired handset
- Product colour
- Grey
- Wall mountable
- Yes
Performance
- Dual-Tone Multi-Frequency (DTMF) modes
- In-band, Out-of band, SIP info
- Hearing aid compatibility
- Yes
Phone features
- Answering machine
- Yes
- Call waiting
- Yes
- Speed dialling
- Yes
- Intercom
- Yes
- Call hold
- Yes
- Call forwarding
- Yes
- Conference call
- Yes
- Redialing
- Yes
- Caller ID
- Yes
- Do not disturb function
- Yes
- Phonebook capacity
- 1000 entries
- Call park
- Yes
- Call pick up
- Yes
- Anonymous call
- Yes
- Anonymous call rejection
- Yes
- Full duplex
- Yes
- Call return
- Yes
- Call transfer
- Yes
- Message-waiting indicator (MWI)
- Yes
Management features
- Integrated voicemail
- Yes
- Keypad number of keys
- 27
- Number of function keys
- 7
Display
- Display
- LCD
- Display diagonal
- 17.8 cm (7")
- Display resolution
- 1024 x 600 pixels
- Touchscreen
- Yes
- Touchscreen type
- Capacitive
Camera
- Front camera
- Yes
- Front camera resolution (numeric)
- 5 MP
Audio
- Speakerphone
- Yes
- Microphone mute
- Yes
- Voice codecs
- G.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
- Noise reduction
- Yes
- Voice activity detection
- Yes
- Adaptive jitter buffers
- Yes
- Automatic gain control
- Yes
- Comfort noise generation (CNG)
- Yes
- Packet loss concealment (PLC)
- Yes
Video
- Video resolutions
- 1280 x 720 pixels
- Video codecs
- H.264 High Profile, H.264, VP8
Network
- Ethernet LAN
- Yes
- Ethernet LAN interface type
- Gigabit Ethernet
- Ethernet LAN data rates
- 1000 Mbit/s
- Wi-Fi
- Yes
- Wi-Fi standards
- 802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
- Bluetooth
- Yes
- Bluetooth version
- 4.2
- Supported network protocols
- IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
- Quality of Service (QoS) support
- Yes
- Security algorithms
- 256-bit AES, HTTPS, TLS, WPA2, WPA3
- Networking standards
- IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Ports & interfaces
- USB 2.0 ports quantity
- 2
- Ethernet LAN (RJ-45) ports
- 2
- RJ-9 ports quantity
- 2
Power
- Power over Ethernet (PoE)
- Yes
- USB output current
- 0.5 A
- Power consumption (Power over Ethernet (PoE))
- 9 W
Operational conditions
- Operating temperature (T-T)
- 0 - 45 °C
- Operating relative humidity (H-H)
- 5 - 90%
Weight & dimensions
- Width
- 259.4 mm
- Depth
- 220 mm
- Height
- 239 mm
- Weight
- 8.88 kg
- Package width
- 324 mm
- Package depth
- 293 mm
- Package height
- 128 mm
- Package weight
- 9.56 kg
Packaging content
- Number of handles included
- 1 pc(s)
Database Right data-sheet 2026 Icecat. All rights reserved. · Specs Icecat