Allied Telesis GS950/10PS Managed Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Green, Grey

Allied Telesis GS950/10PS Managed Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Green, Grey

ALLIED TELESIS

GBP 310.99 There are 3 offers for this product.

Unmanaged. Basic switching RJ-45 Ethernet ports quantity: 8. Rack mounting Stackable. Power over Ethernet (PoE). Management features. Switch type. Unmanaged. Ports & interfaces. Fiber optic connector. SFP. Fiber ports quantity. 2. Basic switching RJ-45 Ethernet ports type. Gigabit Ethernet (10/100/1000). Basic switching RJ-45 Ethernet ports quantity. 8. Network. 10G support. No. Design. Product colour. Grey. Stackable. Yes. Rack mounting. Yes. Power over Ethernet (PoE). Total Power over Ethernet (PoE) budget. 75 W. Power over Ethernet (PoE). Yes

Compare offers

  • Back to the Office Unknown
    GBP 310.99
  • PcNova Unknown
    GBP 351.79
  • GamingKit Unknown
    GBP 422.15

Specifications

Management features

Switch type
Managed
Quality of Service (QoS) support
Yes
Web-based management
Yes
MIB support
RFC 1213 MIB-II, RFC 1215 TRAP MIB, RFC 1493 Bridge MIB, RFC 2863, RFC 1643, RFC 2618 RMON, RFC 2674 IEEE 802.1Q, RFC 2096 IP

Ports & interfaces

Basic switching RJ-45 Ethernet ports quantity
8
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Gigabit Ethernet (copper) ports quantity
10
Combo SFP ports quantity
2
Fiber ports quantity
2
Fiber optic connector
SFP
Console port
RJ-45
Power connector
DC-in jack

Network

Networking standards
IEEE 802.1D, IEEE 802.1p, IEEE 802.1s, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support
No
Copper ethernet cabling technology
10BASE-T, 100BASE-T, 1000BASE-T
Port mirroring
Yes
Full duplex
Yes
Flow control support
Yes
Rate limiting
Yes
VLAN support
Yes

Optical fiber

Fiber ethernet cabling technology
100BASE-FX, 1000BASE‑LX, 1000BASE‑SX
Fiber type
Multi-mode

Data transmission

Switching capacity
20 Gbit/s
Throughput
14.88 Mpps
MAC address table
8000 entries

Security

DHCP features
DHCP client, DHCP server
IGMP snooping
Yes
MAC address filtering
Yes

Multicast features

Multicast support
Yes

Design

Product colour
Green, Grey

Performance

Internal memory
64 MB
Flash memory
16 MB

Power

AC input voltage
100 - 240 V
Power consumption (typical)
13.58 W

Power over Ethernet (PoE)

Power over Ethernet (PoE)
Yes
Power over Ethernet plus (PoE+) ports quantity
8
Total Power over Ethernet (PoE) budget
75 W

Operational conditions

Operating temperature (T-T)
0 - 40 °C
Storage temperature (T-T)
-25 - 70 °C
Operating relative humidity (H-H)
5 - 90%
Storage relative humidity (H-H)
5 - 95%
Operating altitude
0 - 3048 m

Weight & dimensions

Width
330 mm
Depth
200 mm
Height
44 mm
Weight
1.9 kg

Certificates

Certification
RoHS Eu-RoHS China RoHS WEEE

Logistics data

Harmonized System (HS) code
85176990

Database Right data-sheet 2026 Icecat. All rights reserved. · Specs Icecat